Annonces Google
Serveur IRC
Serveur : irc.portlane.se
Canal : #AmigaNG
Activité du Site

Pages vues depuis 25/07/2007 : 25 681 074

  • Nb. de membres 187
  • Nb. d'articles 1 272
  • Nb. de forums 19
  • Nb. de sujets 20
  • Nb. de critiques 24

Top 10  Statistiques

Index du forum »»  OS4 sur A1222 »» erreur sur le 1222

erreur sur le 1222#2769

7Contributeur(s)
Mister-JBAMK-LFaranheitthellierSheldonPseudaxosalex
3 Modérateur(s)
K-LElwoodcorto
K-L K-Licon_post
Pour être bien sûr que tout fonctionne bien, peux-tu tester : http://os4depot.net/share/utility/benchmark/cubebm.lha

Si tu vois le cube tourner, c'est que tout est ok côté NovaBridge.

Et cela signifie que pour WipeOut et Blender, il y a autre chose qui met le bazar (manque de FPU ?).
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
K-L K-Licon_post
Mmm,

D'après ce lien : http://eliyahu.org/tabor/games.html

WipeOut devrait fonctionner (mais ramer grave dès que le son se met à jouer).

En général, les jeux pas encore compilés pour utiliser le SPE de l'A1222, ça va ramer.

Peux-tu aussi tester : http://cherry-darling.net/voxelnoid/download_nohotlink/VoxelNoid_AOS4.lha

Lui est prévu pour utiliser le SPE, tout comme Tower57 (un des tout premiers jeux compilés pour le SPE de l'A1222) : https://benitosub.itch.io/tower-57

Pour Blender, cela devrait fonctionner d'après cette page : http://eliyahu.org/tabor/tools.html
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Mister-JBAM Mister-JBAMicon_post
tout d'abord merci pour ton aide

j'ai remplacé les deux libs de MiniGL par celle trouvée ici https://www.goldencode.de/?page=2
apres plusieurs test j'ai mis la version SPE compatible PPC

Cubem tourne parfaitement
Wipeout tourne mais rame mechament en effet
Voxelnoid tourne mais rame

Par contre blender ne fonctionne toujours pas (et je ne pense qu'une maj vas sortir vue la date de la derniere version)
Shogo non plus ne fonctionne pas (lui a la meme erreur mais a l'installation)
UFOAI ne fonctionne pas non plus

Bref c'est un peu le bordel sur le 1222 (du surrement au maque de FPU)

K-L K-Licon_post
Ces deux jeux ne fonctionnent pas sur A1222 en effet (voir la liste que j'ai mise en lien plus haut).

Oui, il va falloir attendre que de plus en plus de devs aient un A1222 pour recompiler certains programmes pour utiliser correctement le SPE.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Faranheit Faranheiticon_post
Salut ;)
Au moins un très bon développeur a commencé à tatouiller le SPE sur A1222, j'ai nommé Huno !

Daniel Mussener a aussi fait certains jeux en SPE depuis 4 mois ;)

Donc, ça vient, ça bouge ;)

Merci à tous ;)
Faranheit
Amedia Computer France
69, Avenue de la Libération
F-57530 Courcelles-Chaussy
Tel : (+33) 9 79 72 56 15
GSM : (+33) 7 71 10 72 22
Mail : laurent@amedia-computer.com
Site : https://www.amedia-computer.com
Skype : faranheit57
K-L K-Licon_post
Oui, Huno tente des trucs avec le SPE mais c'est pas si simple :( En espérant qu'il ne baisse pas les bras devant la complexité de la chose (il avait abandonné l'utilisation de XMOS sur le X1000 tant c'était chiant).

Daniel a aussi pas mal bossé sur le SPE dès le départ (cf Tower57).
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Mister-JBAM Mister-JBAMicon_post
j'ai quand meme des choses etrange

Ex ; ScummVM version 2.8.0 = fonctionne sans soucis
ScummVM version 2.8.1 = ne se lance pas, j'ai la meme erreur que pour les autres softs
https://drive.google.com/file/d/1cicJbVOPg_dFQg5FXzC7WnD2JUbIQDR0/view?usp=sharing

je ne comprend pas pourquoi
thellier thelliericon_post
1) Tu as essayé d'augmenter la satck ?

genre
newshell
stack 1000000
blender

2) vérifie aussi la version de ixemul.library que veut le prog pour ton erreur gcc thread



3) Par ailleurs les erreurs de tes grabs apprennent rien : 99% des erreurs sont dues à une lecture ou écriture (c le cas ici = STORAGE) à un emplacement mémoire qui existe pas
Par ailleurs l'emplacement de l'erreur est pas toujours (mais souvent) où est la bug= si un prog demande à graphics.library de tracer à tel endroit en mémoire (qui n'existe pas) alors on aura bien un crash dans graphics.library alors que l'erreur venait du prog


Y a une option genre "appels dans la pile" ou "desassemblage" qui est plus utile que le numéro d'erreur
Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
Mister-JBAM Mister-JBAMicon_post
merci pour ton aide

oui j'ai essayé direct d'augmenter la stack (mais sans resultat)
j'ai aussi changé la barrette memoire en pensant qu'elle avait un soucis

reesulats de Appels dans la pile : https://drive.google.com/file/d/1XfFgFdil-KjzAwy9R2E-r5IBL7SxxtYM/view?usp=sharing

resultat de desassemblage : https://drive.google.com/file/d/1xTgpzwt8zKh_fPie0o8Ht-_uUL8H2T-4/view?usp=sharing

si cela te parle je suis preneur de ton analyse car pour moi cela ne me parle pas
Sheldon Sheldonicon_post
Hello,

Eliyahu a testé beaucoup de logiciels ici: http://eliyahu.org/tabor/tools.html

et les jeux ici: http://eliyahu.org/tabor/games.html

Regarder aussi du côté du LTE DEVS:load-time-blacklist (dans le lien ci-dessus)

Pour info le jeu Mist AGA ne fonctionne pas sur sa liste :
mais en ajoutant MYST_AGA.exe et MYST_CGX.exe dans le fichier DEVS:load-time-blacklist le jeux fonctionne.

ps: WipeOut est en cours de portage A1222 SPE par Hunoppc : https://www.youtube.com/watch?v=klPYoCD_Ka8
Work in progress sans son ni musique à 50Fps , prometteur (http://hunoppc.amiga-projects.net/)
il a un site pour l'aider au développement: https://ko-fi.com/hunoppc

côté library minigl: celles qui fonctionnent le mieux mais pas pour tout et nécessite parfois novabridge: https://www.hyperion-entertainment.com/svn/MiniGL/branches/updates-kc/precompiled_binaries.7z à tester car il y a une version native SPE et une autre compatible SPE et PPC.

Cordialement.
Amigalement.
Petites Annonces

0 annonce(s) publiée(s)

Consulter

AmigaOS 4.1

Laissez-vous tenter par
AmigaOS 4.1
AmiTheme

AmiTheme