Annonces Google
Serveur IRC
Serveur : irc.portlane.se
Canal : #AmigaNG
Activité du Site

Pages vues depuis 25/07/2007 : 25 678 601

  • Nb. de membres 187
  • Nb. d'articles 1 272
  • Nb. de forums 19
  • Nb. de sujets 20
  • Nb. de critiques 24

Top 10  Statistiques

Index du forum »»  OS4 sur A1222 »» erreur sur le 1222

erreur sur le 1222#2769

7Contributeur(s)
Mister-JBAMK-LFaranheitthellierSheldonPseudaxosalex
3 Modérateur(s)
K-LElwoodcorto
Faranheit Faranheiticon_post
Salut ;)
Au moins un très bon développeur a commencé à tatouiller le SPE sur A1222, j'ai nommé Huno !

Daniel Mussener a aussi fait certains jeux en SPE depuis 4 mois ;)

Donc, ça vient, ça bouge ;)

Merci à tous ;)
Faranheit
Amedia Computer France
69, Avenue de la Libération
F-57530 Courcelles-Chaussy
Tel : (+33) 9 79 72 56 15
GSM : (+33) 7 71 10 72 22
Mail : laurent@amedia-computer.com
Site : https://www.amedia-computer.com
Skype : faranheit57
K-L K-Licon_post
Oui, Huno tente des trucs avec le SPE mais c'est pas si simple :( En espérant qu'il ne baisse pas les bras devant la complexité de la chose (il avait abandonné l'utilisation de XMOS sur le X1000 tant c'était chiant).

Daniel a aussi pas mal bossé sur le SPE dès le départ (cf Tower57).
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Mister-JBAM Mister-JBAMicon_post
j'ai quand meme des choses etrange

Ex ; ScummVM version 2.8.0 = fonctionne sans soucis
ScummVM version 2.8.1 = ne se lance pas, j'ai la meme erreur que pour les autres softs
https://drive.google.com/file/d/1cicJbVOPg_dFQg5FXzC7WnD2JUbIQDR0/view?usp=sharing

je ne comprend pas pourquoi
thellier thelliericon_post
1) Tu as essayé d'augmenter la satck ?

genre
newshell
stack 1000000
blender

2) vérifie aussi la version de ixemul.library que veut le prog pour ton erreur gcc thread



3) Par ailleurs les erreurs de tes grabs apprennent rien : 99% des erreurs sont dues à une lecture ou écriture (c le cas ici = STORAGE) à un emplacement mémoire qui existe pas
Par ailleurs l'emplacement de l'erreur est pas toujours (mais souvent) où est la bug= si un prog demande à graphics.library de tracer à tel endroit en mémoire (qui n'existe pas) alors on aura bien un crash dans graphics.library alors que l'erreur venait du prog


Y a une option genre "appels dans la pile" ou "desassemblage" qui est plus utile que le numéro d'erreur
Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
Mister-JBAM Mister-JBAMicon_post
merci pour ton aide

oui j'ai essayé direct d'augmenter la stack (mais sans resultat)
j'ai aussi changé la barrette memoire en pensant qu'elle avait un soucis

reesulats de Appels dans la pile : https://drive.google.com/file/d/1XfFgFdil-KjzAwy9R2E-r5IBL7SxxtYM/view?usp=sharing

resultat de desassemblage : https://drive.google.com/file/d/1xTgpzwt8zKh_fPie0o8Ht-_uUL8H2T-4/view?usp=sharing

si cela te parle je suis preneur de ton analyse car pour moi cela ne me parle pas
Sheldon Sheldonicon_post
Hello,

Eliyahu a testé beaucoup de logiciels ici: http://eliyahu.org/tabor/tools.html

et les jeux ici: http://eliyahu.org/tabor/games.html

Regarder aussi du côté du LTE DEVS:load-time-blacklist (dans le lien ci-dessus)

Pour info le jeu Mist AGA ne fonctionne pas sur sa liste :
mais en ajoutant MYST_AGA.exe et MYST_CGX.exe dans le fichier DEVS:load-time-blacklist le jeux fonctionne.

ps: WipeOut est en cours de portage A1222 SPE par Hunoppc : https://www.youtube.com/watch?v=klPYoCD_Ka8
Work in progress sans son ni musique à 50Fps , prometteur (http://hunoppc.amiga-projects.net/)
il a un site pour l'aider au développement: https://ko-fi.com/hunoppc

côté library minigl: celles qui fonctionnent le mieux mais pas pour tout et nécessite parfois novabridge: https://www.hyperion-entertainment.com/svn/MiniGL/branches/updates-kc/precompiled_binaries.7z à tester car il y a une version native SPE et une autre compatible SPE et PPC.

Cordialement.
Amigalement.
K-L K-Licon_post
Sheldon : tu n'as pas lu tout le fil.

Les bibliothèques MiniGL ont bien été installée par Mr Jbam.

J'avais bien déjà donné les liens concernant les jeux et outils testés par Eliyahu.

Mr Jbam : tu as bien installé les dernières versions des bibliothèques SDL2 (sur OS4Depot ou via AmiUpdate) ?
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Mister-JBAM Mister-JBAMicon_post
merci Shledon pour l'info sur load-time-blacklist , je vais regarder cela

K-L : voulant dev en SDL2 sur le 1222 j'ai installé des le debut la 2.30.1 prise sur le github
K-L K-Licon_post
Pour ce qui est de ScummVM, j'ai l'impression que Raziel ne sait jamais trop où il va dans le portage de ce programme.
https://www.amigans.net/modules/newbb/viewtopic.php?topic_id=6866&post_id=147350

Donc, je ne saurais t'en dire plus :(

Perso, je trouve que version après version, ScummVM devient de plus en plus lent, sur les mêmes jeux.

--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
thellier thelliericon_post
Non ça me parle pas non plus
En fait ces debugs sont juste utile quand ça plante dans un programme que tu écris puisque "appels dans la pile" dit dans quelle fonction et offset ça a planté
après si le désassemblage nous dit comme ici que c'est en lisant 16 bits en mémoire alors on peut regarder dans ses source si on a pas un pointeur pas initialisé qui lirait un WORD dans cette fonction = bref ça sert juste au développeur

Mais là ici ça plante dans des library du système donc ça aide pas
elf.library c'est pas ce qui gére les .so ? y aurait pas un so demandé par ce prog avec une mauvaise version ?
Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
Petites Annonces

0 annonce(s) publiée(s)

Consulter

AmigaOS 4.1

Laissez-vous tenter par
AmigaOS 4.1
AmiTheme

AmiTheme