Annonces Google
Serveur IRC
Serveur : irc.portlane.se
Canal : #AmigaNG
Activité du Site

Pages vues depuis 25/07/2007 : 26 122 017

  • Nb. de membres 188
  • Nb. d'articles 1 272
  • Nb. de forums 19
  • Nb. de sujets 20
  • Nb. de critiques 24

Top 10  Statistiques

Index du forum »»  OS4 sur A1222 »» erreur sur le 1222

erreur sur le 1222#2769

7Contributeur(s)
Mister-JBAMK-LFaranheitthellierSheldonPseudaxosalex
3 Modérateur(s)
K-LElwoodcorto
Mister-JBAM Mister-JBAMicon_post
Bonjour

j'ai plusieurs soft qui ne font des erreurs 80000003 au lancement .
ex ; Wipeout
https://drive.google.com/file/d/16VHB9fHy7tUgS3AbfCafDmH1-_oRRKiX/view?usp=sharing

Blender
https://drive.google.com/file/d/1RF_pOS7dek3jxiimcs523QRkG2Ie_TGx/view?usp=sharing

un peu plus d'info
https://drive.google.com/file/d/1-Scc3ChPvjYueqCuVMM8lmGW9WCz8E9z/view?usp=sharing

Avez vous une idée d'ou peux venir le soucis et comment le corriger ?
 Message édité par : Mister-JBAM / 29-03-2024 14:28
K-L K-Licon_post
Il te faut acheter (oui, je sais) NovaBridge qui est un wrapper MiniGL vers Warp3D Nova.

Ces logiciels n'ont pas été compilés pour utiliser directement OpenGLES de Warp3D Nova.

L'avantage de Nova Bridge : tous les softs 3D fonctionnent de manière transparent quelques soient leurs besoin : Warp3D originel, MiniGL, OpenGLES, etc...

Tu peux te baser sur le tutoriel de Kas1e traduit par Daff sur Obligement mais je trouve qu'il est un peu bordélique (il a le mérite d'exister tu me diras) : http://obligement.free.fr/articles/warp3dnova_minigl_ogles2_installation.php

J'ai l'intention, dès que j'ai un moment, d'en faire un plus simple.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
 Message édité par : K-L / 29-03-2024 17:33
Mister-JBAM Mister-JBAMicon_post
Merci pour l'info
je vais tester cela
Mister-JBAM Mister-JBAMicon_post
j'ai acheté NovaBridge (outchhh le prix fait mal)

Sauf erreur de ma part j'ai tout bien installé
j'ai pu lancer : The Vague 2 , M.A.C.E. Tower Defense et H-Craft Championship

Par contre Lodepaint ne se lance pas (unable to resolve symbol '__gthread_one' in System:SObjs/libgcc.so)
Et cela n'a rien changé pour blender et viewpoint j'ai toujours la meme erreur ?



K-L K-Licon_post
M.A.C.E. n'a pas besoin de 3D, il utilise le rendu composite.
De quel Tower Defense tu parles ? M.A.C.E. Defense ? Si oui, il n'avait pas besoin de NovaBridge : fonctionne avec OpenGLES.
Lodepaint se vautre ici, à mon avis il a besoin d'être mis à jour.
Blender fonctionne bien (tu as bien pris la dernière version sur OS4Depot ?). Après, c'est ptet la FPU qui met le bazar.

Tu as testé WipeOut ?

Les autres, je ne sais pas :)

--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Mister-JBAM Mister-JBAMicon_post
oups je me suis trompé ce n'est pas viewpoint mais wipeout
donc oui je l'ai testé et il ne marche toujours pas (comme blender)

pour les autres jeux ce sont ceux qui etait recommandé de tester sur le tuto sur obligement
K-L K-Licon_post
Pour être bien sûr que tout fonctionne bien, peux-tu tester : http://os4depot.net/share/utility/benchmark/cubebm.lha

Si tu vois le cube tourner, c'est que tout est ok côté NovaBridge.

Et cela signifie que pour WipeOut et Blender, il y a autre chose qui met le bazar (manque de FPU ?).
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
K-L K-Licon_post
Mmm,

D'après ce lien : http://eliyahu.org/tabor/games.html

WipeOut devrait fonctionner (mais ramer grave dès que le son se met à jouer).

En général, les jeux pas encore compilés pour utiliser le SPE de l'A1222, ça va ramer.

Peux-tu aussi tester : http://cherry-darling.net/voxelnoid/download_nohotlink/VoxelNoid_AOS4.lha

Lui est prévu pour utiliser le SPE, tout comme Tower57 (un des tout premiers jeux compilés pour le SPE de l'A1222) : https://benitosub.itch.io/tower-57

Pour Blender, cela devrait fonctionner d'après cette page : http://eliyahu.org/tabor/tools.html
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Mister-JBAM Mister-JBAMicon_post
tout d'abord merci pour ton aide

j'ai remplacé les deux libs de MiniGL par celle trouvée ici https://www.goldencode.de/?page=2
apres plusieurs test j'ai mis la version SPE compatible PPC

Cubem tourne parfaitement
Wipeout tourne mais rame mechament en effet
Voxelnoid tourne mais rame

Par contre blender ne fonctionne toujours pas (et je ne pense qu'une maj vas sortir vue la date de la derniere version)
Shogo non plus ne fonctionne pas (lui a la meme erreur mais a l'installation)
UFOAI ne fonctionne pas non plus

Bref c'est un peu le bordel sur le 1222 (du surrement au maque de FPU)

K-L K-Licon_post
Ces deux jeux ne fonctionnent pas sur A1222 en effet (voir la liste que j'ai mise en lien plus haut).

Oui, il va falloir attendre que de plus en plus de devs aient un A1222 pour recompiler certains programmes pour utiliser correctement le SPE.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Petites Annonces

0 annonce(s) publiée(s)

Consulter

AmigaOS 4.1

Laissez-vous tenter par
AmigaOS 4.1
AmiTheme

AmiTheme