Annonces Google
Serveur IRC
Serveur : irc.portlane.se
Canal : #AmigaNG
Activité du Site

Pages vues depuis 25/07/2007 : 25 570 593

  • Nb. de membres 187
  • Nb. d'articles 1 272
  • Nb. de forums 19
  • Nb. de sujets 20
  • Nb. de critiques 24

Top 10  Statistiques

Index du forum »»  Tous sujets »» Linux sur X1000

Linux sur X1000#2551

11Contributeur(s)
K-LPseudaxoszzd10hsinisrusxrayMonsieur-BelettElwoodLioTorajaBoycortosadirux
3 Modérateur(s)
K-LElwoodcorto
K-L K-Licon_post
Il me reste quelque jours de vacances ( :-P ), j'ai pu peaufiner un peu mon installation tant matérielle que logicielle.

Pour profiter de l'accélération 2D et 3D sous Linux, j'ai donc réinstallé la Radeon HD 4650 que j'avais sous le coude.

Sauf que sous OS4, je veux utiliser ma Radeon RX 250.

C'est donc une installation Dual Graphics qu'il a fallu que je fasse.

Je vous passe les détails (sauf si vous me les demandez) mais en bref :

  • Carte Radeon HD 4650 installée sur le Port PCI-Express 16x n°1
  • Carte Radeon RX 250 installée sur le porte PCI-Express 16x n°3


Sous OS4, penser à mettre les deux moniteurs de chaque carte + PCIGraphics dans Devs:Monitors. La configuration est pas forcément simple mais j'ai finalement réussi à faire démarrer AmigaOS4.1 avec la Radeon RX 250.


J'utilise maintenant MATE 2017 0.9 comme distibution Linux, comme je l'avais expliqué. Son installation passant par une copie de son image vers le disque dur, la taille de 15Go de l'image était la limite de taille de mon système d'exploitation alors qu'il est sur une partition de 250 Go.

Pour pallier cela, il faut démarrer sous un autre Linux (mon fameux Ubuntu Remix d'A-Eon que je conserve préciseuement installé) et utiliser GParted pour faire un "check" de la partition, ce qui lui débloquera la taille maximal utilisable (fallait le trouver, ça).


Au début, Liunux refusait d'utiliser la bonne carte. Il a fallu que je comprenne le fonctionnement d u script /etc/X11/xorg.conf et modifier le port PCI Express utilisé pour l'utilisation du système.

Au redémarrage, il utilise bien la 4650. Et ça se sent, le déplacement des fenêtres est très fluide, comme sous OS4.


Côté tests, j'ai pu jouer avec VLC (merdique à configurer pour réussir à avoir une vidéo). Bref, pour profiter d'un minimum d'accélaration vidéo, il faut utiliser le rendu OpenGL.

Par rapport à AmigaOS4.1, la lecture d'une vidéo en 1280x720 passe sans problème (avec une utilisation des deux coeurs à quasiment 80%). Imaginez, vu la qualité et l'optimisation de nos lecteurs vidéo, la vitesse de décodage que l'on aurait si le SMP était implémenté.

J'ai juste un souci : pas moyen de basculer l'affichage en fullscreen : la vidéo garde la taille de départ, c'est un peu idiot, je trouverais peut-être une solution à un moment.


Le changement de carte graphique n'a pas amélioré le chargement des page web avec Firefox : c'est tout autant (voire plus lent) qu'Odyssey sous AmigaOS4.1, avec de plus certaines pages qui font planter le navigateur, bizarrement.


Je vais continuer à tester, j'ai réussi à obtenir déjà un truc plutôt bien utilisable. Donc à suivre... :-)


--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
sinisrus sinisrusicon_post
@K-L

Je me demande si on peut faire du dual screen sur sam460 avec carte graphique et la puce graphique de la carte mère
--
Coin coin... amitheme.amiga-ng.org
Sam460 1,15Ghz - OS4.1FE - Radeon Saphir HD7750 R7 250E - 2Go de ram
Elwood Elwoodicon_post
Normalement oui mais pas comme on le fait sur les autres OS : impossibilité de déplacer une fenêtre d'un écran à un autre. Le WB est sur un écran et il faut ouvrir un programme sur le 2ème écran en lui donnant le MODEID de cet écran. Enfin c'est la théorie. Je sais plus si quelqu'un a déjà essayé...
--
Philippe Ferrucci
Avec une Sam460 et AmigaOS 4.1, je suis eco-responsable. Cool !
K-L K-Licon_post
En théorie oui, mais d'après ce que j'ai lu, le dual screen ne fonctionne pas sous AmigaOS4.1.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
corto cortoicon_post
Bravo K-L pour tes efforts et ta curiosité !

J'avais aussi installé Linux sur X1000 (depuis un DVD gravé) et j'avais aussi un peu galéré, même si je crois qu'en suivant la doc de Xeno, je m'en étais sorti plutôt pas mal. Ce qui est chaud je trouve c'est que ce n'est pas automatique comme sur d'autres matériels et puis il faut s'y connaître pour comprendre les histoires de MESA, de quelles cartes graphiques sont supportées, ...

Je dois dire que j'ai toujours été perdu par leur hyper communication sur les innombrables version du kernel alors qu'on veut juste un DVD d'installation fonctionnel, pouvoir installer des logiciels, ...

J'avais pris des notes sur mon installation ... mais ça remonte.

X1000 - 8GB - Radeon HD6570
Sam440 flex - Radeon 9250
sadirux sadiruxicon_post
Moi j'ai essayé Linux Mate sur le X5000 (avec la carte R7 250 et le kernel d'origine fournit avec l'image), du coup je trouve ça mou, poussif, lent ... vivement le support complet de la R7 250 ...
K-L K-Licon_post
Sadirux : exact, avec la R7 250, le déplacement des fenêtres est poussif. Pour le reste, je pense qu'il y a encore un peu de place pour l'optimisation même si ça reste utilisable au jour le jour.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Petites Annonces

0 annonce(s) publiée(s)

Consulter

AmigaOS 4.1

Laissez-vous tenter par
AmigaOS 4.1
AmiTheme

AmiTheme