Annonces Google
Serveur IRC
Serveur : irc.portlane.se
Canal : #AmigaNG
Activité du Site

Pages vues depuis 25/07/2007 : 24 530 679

  • Nb. de membres 185
  • Nb. d'articles 1 268
  • Nb. de forums 19
  • Nb. de sujets 20
  • Nb. de critiques 24

Top 10  Statistiques

Index du forum »»  OS4 sur Classic »» AmigaOS4.1 sur WinUAE PPC

AmigaOS4.1 sur WinUAE PPC#1926

25Contributeur(s)
SergiusjegougouLioGuibrushzzd10hamigaoufElwoodsinisrusK-LCrisotPseudaxosdavebracothellierCreolsSeptikAmiDARKprocitcortoOlricksadiruxPetrolYesCopTarzinDingopathe
3 Modérateur(s)
K-LElwoodcorto
K-L K-Licon_post
Vu que j'utilise Windows XP, ça vient peut-être de là.

Mais bon, j'ai réussi à avoir quelque chose de stable (mais lent) ou à peu près stable.

L'installation de l'ESP 3 s'est soldé par un figeage de l'émulation.

A noter que lors du basculement en émulation PPC, les deux coeurs du Centrino sont à fond tout le temps (avec ventioilos à fond aussi). Je pense donc qu'en dessous d'un i7 (ou Ryzen), point de salut pour l'émulation.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
thellier thelliericon_post

C e devrait pas être si lent que ça: As tu bien tout mis comme dans mon post du 31-07-2017 09:54 page précédente ?

Alain


Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
zzd10h zzd10hicon_post
Pour ma part, mon UAE/FE se fige systématiquement quand il y a trop d'IO.

C'est peut-être pour ça que le tien a planté lors de l'installation de l'ESP ?
thellier thelliericon_post

Des 3 options de disques

IDE

Scsi

Répertoire partagée

Il y en a carrément de plus lentes et/ou périlleuses que d'autres malheureusement je me rappelle plus ce que j'avais lu sur English Amiga Board sur ce sujet

Je vais y reposer la question


Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
K-L K-Licon_post
zzd10h : c'est exactement cela.

Honnêtement, c'est assez peu utilisable (même avec les optimisations d'Alain) sur un Centrino Duo à 1,8 Ghz (dommage, ça m'aurait fait un portable sympa), surtout que Windows 32 bits limite la mémoire totale dédiée à l'émulation AmigaOS4 à 512Mo (sinon ça cause des soucis).

Là, j'ai repris ma configuration et l'ai installée sur APU AMD 7890K sous Windows 10 et ça tourne bien mieux (je copie la plupart de mes outils, je verrai si ça se vautre). Mais ce n'est pas un portable, juste un PC fixe.

J'utilise le SCSI de la Cyberstorm pour mes images disque.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
K-L K-Licon_post
Bon, ça avance (et ça n'a toujours pas planté en copie) :

--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
thellier thelliericon_post

J'ai posé la question.

Réponse de Toni Wilen le développeur de WinUAE :

"Cyberstorm SCSI"

est le plus sûr/rapide 

Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
Dingopathe Dingopatheicon_post
Bonjour,

Nouveau dans la communauté, sans vraiment l'être, vu qu'il m'est arrivé un Obélix (je crois qu'il n'y pas besoin d'en rajouter plus).

Bref, en attendant d'avoir les moyens d'assouvir cet irrésistible rêve de me prendre un A1222 pas encore sorti, j'ai acheté flowerpot et os4.1FE
Et malgré moult réglages, ça rame sur un bon i5 win10 stable. C'est également freezo-plantogène.

Faut oublier la molette, le pavé numérique aussi, bug graphique en couleurs 32bits, obligé de passer à 16, copié/collé foireux ? j'arrive généralement à faire bugguer le système au bout de 10 mins.

Dans l'état ce type de solution ne fait clairement pas de la bonne pub et ne représente rien de ce je vois sur youtube, sur des PowerAmiga, tellement, mais tellement plus vif.

Que je m'illusionne en rêvant que le génie leadership de Trevor Angel puisse ne serait-ce que nous ramener au même point software que linux début années 2000, sauce amiga et pas linux ou windows.

Tout ce que je fais pour le moment ne sert à rien, c'est scandaleux de perte de temps (à cause de cette affreuse émulation), j'ai même pas encore trouvé de solution pour dézommer une photo 4k pour la voir normalement, j'ai pas acheté l'"enhancer pack" vu comme ça rame, mais AmigaOS c'est beau, c'est moderne, magnifique même. Heureux qu'ils n'aient pas cédés aux sirènes du flat design.

Je comprend que certains puisse reprocher des choses à hyperion, mais un christophe collomb un peu bidouilleur ne peut que trouver magique ce qu'il voit s'afficher sur son écran.

Bonnes fêtes



Message édité par : Dingopathe / 22-12-2017 22:47
Message édité par : Dingopathe / 22-12-2017 22:48
K-L K-Licon_post
Salut et bienvenue !

Je vois que tu as quand même pas trop mal configuré ton système :-)

J'ai à peu près fiabilisé mon émulation mais bon, honnêtement, ça ressemble plus à une Sam440 à 533Mhz sans accélération 2D qu'autre chose (et je parle pas de la vitesse de chargements des pages dans Odyssey).

Note aussi que sur un portable, j'avais constamment des plantages : c'était dû à la surchauffe des 2 coeurs utilisés pour l'émualtion. Depuis, je fais des essais avec AMD APU 7890K en tour, bien mieux ventilé.

Pour visualiser les images, en effet : soit l'ESP 1.3 soit les zTools (qui incorporent FastView, très pratique).

Honnêtement, actuellement, pour vraiment pouvoir découvrir AmigaOS4.1, je ne peux que conseiller au minimum une Sam440 Flex à 733/800 Mhz (même pas un amigaOne G3 ou G4, trop ancien et parfois sujet aux plantages) mais pas une Sam440ep (limitée en mémoire vive).

L'A1222 sera sûrement une bouffée d'oxygène, le X5000 en est une aussi. La Sam460, bien configurée, est un excellent système aussi pour se faire plaisir avec AmigaOS4.1

Si l'on veut rester dans l'émulation, je conseillerais un CPU de toute dernières génération (un bon gros Ryzen ou Core i9) en tour, bien refroidi.

Note : j'ai résolu les gels lors des accès disques en passant les partitions en SFS.

Pour le pavé numérique, on a tous ce problème :-(

Oui, l'émulation PowerPC dans WinUAE, oui c'est du beau boulot pour teser des trucs mais ça ne peut vraiment pas remplacer un vrai système PowerPC.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
thellier thelliericon_post
bug graphique en couleurs 32bits

Essaye

RTG board
UAE Zorro III
16MB ou plus
8bits
R5G6B5PC
24 Bits
A8R8G8B8

Sinon on peut pas mettre la faute sur les concepteurs d'OS4 si WinUAE est lent
C'est normalement lent puisque tout est rendu en soft = normal

Pour que ça aille vraiment plus vite il faudrait des drivers "natifs" comme dans WinUAE-68k (exemple mon Wazp3D)
Or Toni Willen n'a pas l'air pressé d'implémenter une "native interface" accessible aux coders tiers (qui pourraient alors améliorer sans lui SON WinUAE)
C'est à lui qu'il faut la réclamer...




Sam440 - Sam460 - X5000 - PowerBookG4 - WinUAE - MiniMig
Petites Annonces

0 annonce(s) publiée(s)

Consulter

AmigaOS 4.1

Laissez-vous tenter par
AmigaOS 4.1
AmiTheme

AmiTheme