Annonces Google
Serveur IRC
Serveur : irc.portlane.se
Canal : #AmigaNG
Activité du Site

Pages vues depuis 25/07/2007 : 26 122 302

  • Nb. de membres 188
  • Nb. d'articles 1 272
  • Nb. de forums 19
  • Nb. de sujets 20
  • Nb. de critiques 24

Top 10  Statistiques

Index du forum »»  Création-Développement »» smTube : lecture directe YouTube Qt

smTube : lecture directe YouTube Qt#1657

22Contributeur(s)
zzd10hLioCreolsartblinksinisrusxrayElwoodK-LdavebracoPseudaxosPetrolCrashMidnickjegougoupioupiouastrofrasamo79YesCopnumber-oneEggmanTarzinMurakamiskynet
3 Modérateur(s)
K-LElwoodcorto
K-L K-Licon_post
AioStream devrait faire l'affaire mais il est peu casse bonbons à configurer. Une fois fait, ça tourne plutôt pas mal :)
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
Lio Lioicon_post
j'utilise yt et il fait le job, il faut lui fournir l'url de la vidéo et après tu peux soit la visionner soit la télécharger pour la visonner plus tard.
tout comme aiostream il faut mettre la main à la pâte pour le configurer (pas essayé aiostream donc je ne sais pas si lequel des deux est le plus facile).
A1G4/Radeon9000PRO/1Go RAM; X5000/RadeonR7-250x/2Go RAM; AOS4.1FE
CrashMidnick CrashMidnickicon_post
Merci les gars, je vais tester ça ;)
Pegasos 2 1Ghz/Radeon 9000 PRO/SB live/USB2/OS4.1 FE
Gamme complète des classic 68K/PPC
CrashMidnick CrashMidnickicon_post
Bon testé et c'est pas la fête du slip !

1) Odyssey, dernière version, est à l'ouest : il ne m'affiche pas les vignettes dans Youtube (desktop ou mobile)
2) En spoofant, seules les versions ipad/Wiiu affichent les vignettes
3) La recherche est cassée avec le spoof ipad, le spoof wiiu ne permet pas de lancer le script YT
4) Il doit y avoir un (bon) bug mais des fois j'arrive à avoir la version mobile standard en spoofant wiiu et là ça fonctionne
5) Avec le bug ci-dessus, faut pas toucher au bouton fullscreen sinon guru (et de toute manière ça ne marche pas)

Du coup je passe par une recherche web google traditionnelle et clique sur videos pour avoir le listing. De là je lance le script et ça fonctionne à tous les coups (mais pas de plein écran).

J'espère qu'une solution verra le jour, pour le moment je lancerai Morphos et Wayfarer qui eux fonctionnent tip top.
Pegasos 2 1Ghz/Radeon 9000 PRO/SB live/USB2/OS4.1 FE
Gamme complète des classic 68K/PPC
K-L K-Licon_post
Avec aiostreams, on peut obtenir des résultats sympas : https://video.amiga-ng.org/w/kgM94MRF2bngfizdiGrvBH

J'expliquerai plus en détail comment faire (mais sinon, la doc est assez explicite) si besoin.

Là, c'est Emotion avec le décodage matériel activé qui lit la vidéo. Sauf qu'on voit pour le moment les limites du décodage hardware par le GPU avec le pilote Radeon HD v5 : quand le GPU suit plus, le son coupe régulièrement.

Désolé pour bourdonnement en fond sonore, la puce audio du X1000 me semble pas très bien isolée de parasites et mon video capture (un des rares avec une entre jack) laisse tout passer. Tant qu'on aura pas le son via HDMI, ça sera jamais vraiment top la capture vidéo (sauf avec un boîter bien plus onéreux que ce que j'ai).
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
CrashMidnick CrashMidnickicon_post
Merci !

Tu as du bol, visiblement la recherche fonctionne chez toi. Tu as spoofé en iPad ? Une config spéciale dans Odyssey ?
Je ne voulais polluer mon système avec Python mais Aiostreams fait exactement ce que je recherche. Je vais tester dès que j'ai 5 min.


Pegasos 2 1Ghz/Radeon 9000 PRO/SB live/USB2/OS4.1 FE
Gamme complète des classic 68K/PPC
K-L K-Licon_post
Tu spoofes en iOS pour iPhone.

Pour la recherche, regarde la vidéo, elle ne marche pas au début, tu te remets dessus et tu appuies sur Entrée une nouvelle fois pour que celle-ci fonctionne.

Python est installé par défaut sur AmigaOS 4.1.

Pense à bien configurer aiostreams (voir la doc), sinon, dis-moi où tu bloques et j'essaierai de t'aider.
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
skynet skyneticon_post
Salut à tous,

j'essaie d'utiliser youtube.py, j'ai bien suivi la doc mais rien n'y fait cela crash l'Amiga.

même quand je clique sur l'icône python cela fait planter l'Amiga quand j'indique juste youtube.py dans le shell cela plante aussi!

Que fais-je de faux?
AmigaONE X5040/2,2 Ghz (A-Eon), Radeon RX560, 4 Go de Ram et OS4.1.2 FE - Vampire V4SA et OS 3.2.2.1
K-L K-Licon_post
Tu utilises quel lecteur vidéo ?
--
AmigaONE X1000/1,8 Ghz (A-Eon), Radeon RX560, 2 Go de Ram et OS4.1 FE
skynet skyneticon_post
Emotion téléchargée depuis Amistore.
J'ai essayé plusieurs choses avec python mais toujours le même résultat, pas de réponse et plantage de l'Amiga.
AmigaONE X5040/2,2 Ghz (A-Eon), Radeon RX560, 4 Go de Ram et OS4.1.2 FE - Vampire V4SA et OS 3.2.2.1
Petites Annonces

0 annonce(s) publiée(s)

Consulter

AmigaOS 4.1

Laissez-vous tenter par
AmigaOS 4.1
AmiTheme

AmiTheme