Bienvenue sur Le site des utilisateurs francophones actuels et futurs d'AmigaOS 4.x
Recherche
15 visiteur(s) et 0 membre(s) en ligne.
 
 
    Annonces Google

    Petites Annonces

il y a 1 annonces
    Liens

Toutes les informations sur :
  • Amiga OS 4:
    AmigaOS.net
  • Logiciels pour OS4 :
    OS4depot
  • Matériel Amiga :
    ACube Systems
  • Magazine papier :
    AmigaPower
  • Magazine en ligne :
    Obligement
  •     Activité du Site

    Pages vues depuis 25/07/2007 : 105 783
    • Nb. de Membres : 175
    • Nb. d'articles : 1 075
    • Nb. de Forums : 17
    • Nb. de Sujets : 17
    • Nb. de Critiques : 19

    Top 10  Statistiques

      
    Modéré par : K-L Creols Elwood 
    Index du Forum > > Logiciels > > Symphonie sur AmigaOS 4.1
    AuteurSymphonie sur AmigaOS 4.1
    K-L
    4433       

    K-L
      Posté : 10-04-2017 21:53

    Comme j'ai déjà saoulé certains avec Symphonie, j'ai envie de crier Victoire !

    Ben oui, à force d'acharnement j'ai réussi à faire fonctionner le plus puissant des trackers jamais créés pour Amiga 68k.

    Symphonie proposait des modules multivoies avec des effets de malade (via un DSP logiciel).

    C'est simple, pour en profiter pleinement sur Amiga, il fallait au moins un 68060.

    Sauf qu'il tape directement dans le device.audio et n'utilise pas du tout AHI. Aucun player n'existe autre que le player originel codé en assembleur.

    Pas moyen de le faire fonctionner correctement sous RunInUAE non plus (il se vautre avec une erreur).

    J'avais abandonné tout espoir et puis je me suis dit : allez, réessaie, y a forcément une solution.

    Et je me suis rappelé de NallePuh, un petit patch porté sur OS4 qui redirige les appels de Paula vers AHI (existe aussi pour 68k).

    Plusieurs essais plus tard (grésillements, plantages, etc...), j'ai enfin obtenu le rendu parfait !!

    Pour ceux qui veulent découvrir tout ça, voici un petit tutoriel :

    On récupère NallePUH
    On récupère Symphonie 3.3d

    Alors, comment que ça fonctionne ?

    Avant de lancer Symphonie, on va d'abord rediriger les appels de l'audio.device vers AHI :

    c:NallePUH 0x00030002 44100

    La première option est le mode AHi que l'on veut utiliser : Unit 0:HiFi 16 bit Stereo++

    La seconde option est la fréquence. J'ai mis 44100.

    Ensuite, on peut lancer Symphonie. Et il y une chose à modifier avant de charger un module : le buffer système. Il m'a fallu un moment pour trouver mais il faut le régler au minimum (2) dans le menu Prefs/System/Set System Buffer sinon ça grésille à mort.

    Ensuite, vous pouvez charger un module (pas une Song) et le jouer. Sachez que vous ne ferez rien d'autre qu'écouter les nombreuses créations sorties sur aminet à l'époque (dont certaines magnifiques) car si vous essayez de créer un module avec, cela vous amènera rapidement à un crash.

    Bonne écoute !

    Et vive la puissance des systèmes NG

    Message édité par : K-L / 11-04-2017 19:29

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    Elwood
    3358       

    Elwood
      Posté : 11-04-2017 18:15

    Balaise.
    Je vais écouter ça dès que possible.

    J'avais jamais entendu parler de ce Symphonie avant que tu en parles

    Pas lié mais en cherchant des infos sur ce programme, j'ai trouvé :
    Sympa, par contre j'ai plus de platine vynil depuis longtemps


    --
    Philippe Ferrucci
    Avec une Sam460 et AmigaOS 4.1, je suis eco-responsable. Cool !

    Message édité par : Elwood / 11-04-2017 18:16
    Message édité par : Elwood / 11-04-2017 19:46

      Afficher le profil de ElwoodProfil  Ouvrir le site web de Elwoodwww  Imprimer ce commentaireImprimer
    K-L
    4433       

    K-L
      Posté : 11-04-2017 19:39

    En même temps, je suis persévérant quand je veux quelque chose :


    A un moment, faut se prendre par la main

    J'étais même en train de me dire : pourquoi pas un 1200 avec une 68060 ou une future Vampire. Mais bon, inutile en fait puisque cela marche sur le X1000 et sur la Sam440.

    Certains modules 32 voies peuvent prendre jusqu'à 40% de puissance CPU du X1000 (en émulation 68k JIT / Petunia).


    --
    AmigaONE X1000/1,8 Ghz (A-Eon), Radeon HD 7770, 2 Go de Ram et OS4.1 FE
    Sam440ep/733Mhz (ACube), Radeon M9, 512Mo de RAM et OS4.1 FE

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    Elwood
    3358       

    Elwood
      Posté : 11-04-2017 19:58

    Par contre tu donnes le chemin de Nalle Puh pour OS4, par pour OS3 qui est : NallePUH.lha

    --
    Philippe Ferrucci
    Avec une Sam460 et AmigaOS 4.1, je suis eco-responsable. Cool !

    Message édité par : Elwood / 11-04-2017 19:59

      Afficher le profil de ElwoodProfil  Ouvrir le site web de Elwoodwww  Imprimer ce commentaireImprimer
    K-L
    4433       

    K-L
      Posté : 11-04-2017 20:21

    Ben oui, pourquoi veux-tu utiliser NallePuh OS3 sur OS4 ? Bizarre.

    Je me suis mal expliqué ?


    --
    AmigaONE X1000/1,8 Ghz (A-Eon), Radeon HD 7770, 2 Go de Ram et OS4.1 FE
    Sam440ep/733Mhz (ACube), Radeon M9, 512Mo de RAM et OS4.1 FE

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    Elwood
    3358       

    Elwood
      Posté : 11-04-2017 20:33

    Ah mince. Vu que tu parles de RunInUAE, je supposais que tu l'utilisais.
    Mais ça change tout alors.... Je reteste... => crash
    Tu l'as mis dans Prefs/Compatibility ?

    Sinon les sources sont dispos sur Github. Quelqu'un pourrait le refaire sous OS4. On fait un bounty ?

    Pour être un peu plus complet, il y a un player en Java sur Aminet. Il fonctionne pas sur tous les .mod mais c'est déjà bien (source inclus). Sur Windows, il suffit de faire un double-clic sur le fichier SymReader.jar


    --
    Philippe Ferrucci
    Avec une Sam460 et AmigaOS 4.1, je suis eco-responsable. Cool !

    Message édité par : Elwood / 11-04-2017 20:52
    Message édité par : Elwood / 11-04-2017 20:58

      Afficher le profil de ElwoodProfil  Ouvrir le site web de Elwoodwww  Imprimer ce commentaireImprimer
    K-L
    4433       

    K-L
      Posté : 11-04-2017 20:57

    Oui, il faut bien lancer Symphonie Player Pro sous OS4 (ne pas lancer les autres exécutables).

    Il faut au préalable avoir lancé dans un Shell : NallePuh 0x00030002 44100
    sinon Symphonie Player Pro ne se lancera pas.

    Sur Sam440 avec un module 32 voies et la consommation CPU :



    --
    AmigaONE X1000/1,8 Ghz (A-Eon), Radeon HD 7770, 2 Go de Ram et OS4.1 FE
    Sam440ep/733Mhz (ACube), Radeon M9, 512Mo de RAM et OS4.1 FE
    Message édité par : K-L / 11-04-2017 21:11

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    Elwood
    3358       

    Elwood
      Posté : 11-04-2017 21:04

    Pas mieux avec le player pro. Tu me montreras ça la semaine prochaine.

    --
    Philippe Ferrucci
    Avec une Sam460 et AmigaOS 4.1, je suis eco-responsable. Cool !

      Afficher le profil de ElwoodProfil  Ouvrir le site web de Elwoodwww  Imprimer ce commentaireImprimer
    Sauter à :


    Tous les Logos et Marques sont déposés, les commentaires sont sous la responsabilité de ceux qui les ont publiés. AmigaOS 4.x est (c) Hyperion Entertainment

    Conception graphique du thème : PowerMetal, codage : Alexandre Balaban
    Certaines images sont © Martin \"Mason\" Mertz

    Temps : 1503406123.441 seconde(s)