Bienvenue sur Le site des utilisateurs francophones actuels et futurs d'AmigaOS 4.x
Recherche
14 visiteur(s) et 0 membre(s) en ligne.
 
 
    Annonces Google

    Petites Annonces

il y a annonces
    Liens

Toutes les informations sur :
  • Amiga OS 4:
    AmigaOS.net
  • Logiciels pour OS4 :
    OS4depot
  • Matériel Amiga :
    ACube Systems
  • Magazine papier :
    AmigaPower
  • Magazine en ligne :
    Obligement
  •     Activité du Site

    Pages vues depuis 25/07/2007 : 105 767
    • Nb. de Membres : 175
    • Nb. d'articles : 1 065
    • Nb. de Forums : 17
    • Nb. de Sujets : 17
    • Nb. de Critiques : 19

    Top 10  Statistiques

      
    Modéré par : K-L Creols Elwood 
    Index du Forum > > Création-Développement > > zTools sur AMIStore (anciennement zzdBidules)
    32 pages [ 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 ]
    AuteurzTools sur AMIStore (anciennement zzdBidules)
    zzd10h
    3767       

    zzd10h
      Posté : 22-09-2015 23:53

    Ah ben flute alors, c'est une nouvelle fonction ?
    C'est étrange, à la compilation sous 4.1.6 avec l'ancien SDK, gcc ne semblait se plaindre que pour le tag BMA_TagPixelFormat et pas pour la fonction en elle même mais j'ai peut-être pas fait gaffe.

    Et je ne peux pas vérifier pour l'instant.

    "C'est toi le développeur..."
    J'ai demandé à de vrais devs sur Hyperion :


    Pour l'instant, ColinW n'a pas eu l'air étonné par l'AllocBitMapTags() en 4.1.6.



    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE
    Message édité par : zzd10h / 22-09-2015 23:55

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    YesCop
    306      

    YesCop
      Posté : 23-09-2015 00:09

    Ok. J'ai remis l'ancienne version.
    Je n'avais pas qu'Amistore gardait les téléchargements.

    Sinon, je viens de chercher dans le sdk 4.1.6 et pas d'AllocbitmapTAGS.
    le tags est en trop. Donc ce n'est pas une affaire de paramètre.
    Le code pourrait fonctionner si dans le sdk fe, il existe une fonction AllocBitmap (sans le tags, logiquement il devrait en avoir une) car les paramètres semblent identiques entre les deux sdks.




    Sam Flex 800 Mhz Amiga OS4.1.6

      Afficher le profil de YesCopProfil  Imprimer ce commentaireImprimer
    zzd10h
    3767       

    zzd10h
      Posté : 23-09-2015 00:29

    Merci d'avoir vérifier mais il manquerait de toute façon BMA_TagPixelFormat en 4.1.6.
    Colin a répondu sur Hyperion, Elwood avait raison, c'est une nouvelle fonction.

    Je vais devoir faire des tests de version...


    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    Creols
    2543       

    Creols
      Posté : 23-09-2015 06:45

    Citation: zzd10h 

    Merci d'avoir vérifier mais il manquerait de toute façon BMA_TagPixelFormat en 4.1.6.
    Colin a répondu sur Hyperion, Elwood avait raison, c'est une nouvelle fonction.

    Je vais devoir faire des tests de version...

    @zzd10h Comment oses-tu douter de Elwood ?
    Un comble !
    Creol's qui surveille... de temps à autre!


    -- Sam 460 + X1000

      Afficher le profil de CreolsProfil  Imprimer ce commentaireImprimer
    thellier
    774      

    thellier
      Posté : 23-09-2015 10:18

    Guillaume tu utilise une nouvelle fonction voire un nouveau parametre et tu t'étonne que ça marche pas sous 4.1.6

    Tu es fatigué vaut mieux ne plus programmer ces jours ci

    Alain


    Sam440 - Sam460 - PowerBookG4 - WinUAE - MiniMig

      Afficher le profil de thellierProfil  Imprimer ce commentaireImprimer
    zzd10h
    3767       

    zzd10h
      Posté : 23-09-2015 10:26

    Oui, ok, j'ai compris...
    Je pensais que c'était une ancienne fonction.

    J'ai mis un contrôle de la graphics.library.
    Si FE -> AllocBitMapTags
    Si 4.1.6 -> p96AllocBitmap

    ça marche en 4.1.6 et FE mais bien sûr les warnings un p96 obsolétes sont revenus.

    Je vais modifier tous mes progs et relivrerais pour la màj d'octobre.


    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    YesCop
    306      

    YesCop
      Posté : 23-09-2015 10:45

    quoi ?
    Octobre?

    TU crois que je vais attendre tout ce temps.
    Bon une semaine !!!!

    D'un autre côté, Alain a raison, cela te permettra de te reposer.
    Moi qui pensais que nous avions un Dieu dans ce groupe.
    Je suis déçu. :(

    Je vais prendre une autre idole, pourquoi pas Alain?
    J'ai suivi avec intérêt son travail pendant l'été. Impressionant.




    Sam Flex 800 Mhz Amiga OS4.1.6

      Afficher le profil de YesCopProfil  Imprimer ce commentaireImprimer
    zzd10h
    3767       

    zzd10h
      Posté : 23-09-2015 11:24

    Oui, j'en ai besoin mais je suis sur un autre projet OS4 qui me prends tout mon temps de "loisir".


    Heureusement qu'il y a le boulot pour se reposer, z/OS est beaucoup plus simple qu'AOS  



    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE
    Message édité par : zzd10h / 23-09-2015 11:26

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    YesCop
    306      

    YesCop
      Posté : 24-09-2015 00:23

    Un autre projet?
    Raconte, je veux tout savoir!!!!




    Sam Flex 800 Mhz Amiga OS4.1.6

      Afficher le profil de YesCopProfil  Imprimer ce commentaireImprimer
    zzd10h
    3767       

    zzd10h
      Posté : 24-09-2015 22:54

    @YesCop

    Hop, version d'octobre de zTools envoyé par mail.
    Merci de testouiller tout ça (OK sur ma 4.1.6).


    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    Aller à la page : [ 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 ]
    Sauter à :


    Tous les Logos et Marques sont déposés, les commentaires sont sous la responsabilité de ceux qui les ont publiés. AmigaOS 4.x est (c) Hyperion Entertainment

    Conception graphique du thème : PowerMetal, codage : Alexandre Balaban
    Certaines images sont © Martin \"Mason\" Mertz

    Temps : 1498442236.0755 seconde(s)