Bienvenue sur Le site des utilisateurs francophones actuels et futurs d'AmigaOS 4.x
Recherche
18 visiteur(s) et 1 membre(s) en ligne.
 
 
    Annonces Google

    Petites Annonces

il y a annonces
    IRC

Serveur : irc.portlane.se
Canal : #AmigaNG
    Liens

Toutes les informations sur :
  • Amiga OS 4:
    AmigaOS.net
  • Logiciels pour OS4 :
    OS4depot
  • Matériel Amiga :
    ACube Systems
  • Magazine papier :
    AmigaPower
  • Magazine en ligne :
    Obligement
  •     Activité du Site

    Pages vues depuis 25/07/2007 : 106 138
    • Nb. de Membres : 183
    • Nb. d'articles : 1 227
    • Nb. de Forums : 18
    • Nb. de Sujets : 17
    • Nb. de Critiques : 24

    Top 10  Statistiques

      
    Modéré par : K-L Elwood corto 
    Index du Forum > > OS4 sur Pegasos2 > > USB interne et Pegasos 2
    2 pages [ 1 | 2 ]
    AuteurUSB interne et Pegasos 2
    BatteMan
    142     

    BatteMan
      Posté : 05-06-2016 23:23

    Ca y est , j'ai enfin réussi à démarrer le Pegasos 2 qui m'a été très généreusement offert !

    Alors, l'installation aura été compliquée, que ce soit de la machine en elle-même ou d'AmigaOS4.1 FE même, mais j'y suis finalement arrivé.

    Toutefois, j'ai toujours un souci, voire deux, avec AmigaOS4.1 FE. Autant l'USB fonctionne bien sous MorphOS (3.0 ou 3.9), autant sous OS4 rien, nada, que pouic... En effet, que ce soit en bootant sur le CD d'OS4 ou sur la version installée sur HD, pas moyen d'avoir d'USB interne (je n'ai pas encore de carte USB 2.0 PCI, mais ça ne saurait tarder vu comme ça merdouille et vu comme c'est pratique l'USB quand même...).

    Que ce soit avec l'un ou l'autre des démarrages, j'ai une erreur "There are unsolvable problems with the UHCI Controller" avec comme possibilité de "Reset controller" ou "Stop controller"... Et que je clique sur l'un ou l'autre, cela ne change rien.

    Dans USBInspector, j'ai bien deux "hub" (le front et le rear" qui sont en uhci.usbhcd/1 et 0) qui n'ont pas de numéro de série ou de sous-classe (je ne sais pas si c'est normal...).

    Si certains d'entre vous ont une idée/solution, je suis évidemment preneur.

    Merci d'avance à vous ^^


    Pour le deuxième souci, c'est juste que j'ai l'impression qu'OS4 ne gère que le port GigaEthernet du Pegasos 2 et que j'ai l'impression que ce dernier est moins "compatible" avec le réseau de ma maison... Me trompé-je ? ^^


    PS : Vous avez une liste des indispensables à installer sous OS4 ? Y'a des incontournables ? Y'a un pack style Chrisalys ? ^^


    --
    /me a enfin une machine sous OS4, il pourra enfin essayer les applis de zzd10h, Glames, Huno et les autres ^^


    Pegasos 2, Radeon 9000 64 Mo, 1 Go de mémoire, AmigaOS4.1 FE + MorphOS 3.9 en multiboot !
    Message édité par : BatteMan / 05-06-2016 23:33

      Afficher le profil de BatteManProfil  Ouvrir le site web de BatteManwww  Imprimer ce commentaireImprimer
    K-L
    5391       

    K-L
      Posté : 05-06-2016 23:36

    Indispensables : les zTools (via AmiStore). En émulation : FBA et Snes9x de Huno. smTube de zzd10h pour le port OS4 (nécessite l'installation de QT). Pour le web et le mail : comme sur MOS (Odyssey et YAM/SimpleMail).




    --
    AmigaONE X1000/1,8 Ghz (A-Eon), Radeon HD 7770, 2 Go de Ram et OS4.1 FE

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    zzd10h
    3909       

    zzd10h
      Posté : 06-06-2016 00:12

    @Batteman
    Pour le port Ethernet, en effet, OS4 ne gére que le plus lent des 2 sur Peg2 (le VIA-RHINE, pas le MARVELL). 
    Quand j'avais un Peg2 également, MOS gérait bien les 2 ports mais pas OS4. Par contre, je n'avais pas de soucis avec le port restant sur OS4.

    Pour l'USB, j'avais une carte PCI.

    Ma config de l'époque 



    @K-L
    Merci pour la pub.
     


    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    BatteMan
    142     

    BatteMan
      Posté : 06-06-2016 16:37

    Merci messires K-L et zzd10h !

    Bon, je comprends pourquoi le Via-Rhine est moins rapide que le Marvell puisque celui que je prenais pour un port Gigabit n'en est pas un ^^

    Va falloir que je creuse mon souci de réseau (quand le Peg va sur le réseau, la PS3 se déconnecte... alors qu'ils n'ont pas la même IP... mais les deux sont sur le même switch... va comprendre Charles).

    Je vais voir pour installer tout ça et voir comment ça tourne.

    PS : Pour l'USB, tout le monde passe par une carte USB 2.0 ? Par contre, faut conserver un clavier PS/2 pour l'openfirmware ? Au pire, je peux modifier mon bootmenu à loisir mais cela signifie que je dois d'abord booter une fois, faire la modif' dans le menu et rebooter. Pas contraignant, mais pas très classe ^^

    Merci pour vos réponses !

    Suite de mes pérégrinations en rouge bientôt !

    --
    /me fait le chemin opposé de K-L ! ^^


    Pegasos 2, Radeon 9000 64 Mo, 1 Go de mémoire, AmigaOS4.1 FE + MorphOS 3.9 en multiboot !

      Afficher le profil de BatteManProfil  Ouvrir le site web de BatteManwww  Imprimer ce commentaireImprimer
    K-L
    5391       

    K-L
      Posté : 06-06-2016 17:22

    Pas vraiment le chemin opposé, j'ai utilisé la Sam440 tout le week-end à l'AmigaOufParty (merci Huno pour la motivation ).

    Oui, pars sur une carte USB2 NEC, les mieux supportées


    --
    AmigaONE X1000/1,8 Ghz (A-Eon), Radeon HD 7770, 2 Go de Ram et OS4.1 FE

      Afficher le profil de K-LProfil    Imprimer ce commentaireImprimer
    Eggman
    68    

    Eggman
      Posté : 06-06-2016 20:05

    Pour l'usb, j'ai on contrôleur usb2
    Le contrôleur interne usb 1 serait suffisant pour clavier et souris, mais en réalité, l'of est tout buggué côté usb et beaucoup de claviers et souris usb font déconner la machine au boot et rendent inaccessible l'of, alors qu'ils fonctionnent parfaitement avec Morphos/AOS.
    Du coup, ps/2 pour le clavier et la souris et contrôleur usb2 pour le reste.


    quadra fortuné nostalgique

      Afficher le profil de EggmanProfil  Imprimer ce commentaireImprimer
    BatteMan
    142     

    BatteMan
      Posté : 06-06-2016 21:24

    K-L : Quand je disais ça, je pensais plutôt au MorphOSien convaincu qui teste OS4, tout comme toi l'OS4ien convaincu que tu es à tester assez longuement et en profondeur MorphOS. Je ne pense clairement pas passer sous OS4 à 100%, je vais juste tester et essayer les logiciels des copains ^^


    Eggman : Oui, mais même souris ou clavier sur l'USB interne, ça ne fonctionne pas... Je n'ai tout simplement pas d'USB interne sur le Pegasos 2 sous OS4... 
    Donc pas de clé USB non plus, pas de clavier, pas de souris et autre... alors que ça fonctionne pourtant très bien sous MorphOS.


    Ne pas utiliser le port Gigabit ethernet me gêne quand même et je pense que ça peut être ça le souci avec mon switch... je pense que je vais voir pour choper une carte PCI ethernet du coup (en plus de la carte USB2 et de la carte SATA).

    Tiens, ça me fait penser à autre chose, quel adaptateur IDE->SATA, pour brancher sur le port IDE interne me conseillerez-vous ? Ou alors, je récupère un adapteur IDE->CF/SD vu que ce n'est que pour mettre la partition de boot et les deux partitions système... Hum...

    --
    /me se tâte ! ^^


    Pegasos 2, Radeon 9000 64 Mo, 1 Go de mémoire, AmigaOS4.1 FE + MorphOS 3.9 en multiboot !
    Message édité par : BatteMan / 06-06-2016 21:25

      Afficher le profil de BatteManProfil  Ouvrir le site web de BatteManwww  Imprimer ce commentaireImprimer
    CrashMidnick
    207     

    CrashMidnick
      Posté : 06-06-2016 22:02

    Etrange Battou pour l'USB interne et le réseau (surtout pour le réseau).

    Pour l'USB interne, seul 1 de mes 3 claviers passe au boot... va comprendre et je crois que c'est le seul qui n'est pas certifié PS/2 lol. Tous marchent sans souci sur la prise PS/2.

    EDIT :) : http://www.amiga-ng.org/viewtopic.php?topic=2051&forum=3>




    Message édité par : CrashMidnick / 06-06-2016 22:07

      Afficher le profil de CrashMidnickProfil  Imprimer ce commentaireImprimer
    BatteMan
    142     

    BatteMan
      Posté : 06-06-2016 22:28

    Crashou : Le réseau fonctionne bien, mais je crois que j'ai un switch gigabit et quand je connecte à la fois la PS3 et le Peg2 en 10/100, ça merde. Là, suis sur le Peg2 sous MOS en Gigabit et la PS3 fonctionne... Donc je valide le souci qui n'en est pas un.

    Pour l'USB, là, c'est plus chiant, parce que je n'ai tout simplement pas d'USB... sous OS4...

    J'ai essayé de bidouiller le kicklayout mais ça change rien. Enfin, si je désactive le kmod uhciusb, je n'ai plus le message d'erreur... mais je n'ai pas plus d'USB ^^

    --
    /me ne comprend pas trop...


    Pegasos 2, Radeon 9000 64 Mo, 1 Go de mémoire, AmigaOS4.1 FE + MorphOS 3.9 en multiboot !

      Afficher le profil de BatteManProfil  Ouvrir le site web de BatteManwww  Imprimer ce commentaireImprimer
    BatteMan
    142     

    BatteMan
      Posté : 06-08-2016 14:00

    Suite de mes pérégrinations en terre rouge !

    Je suis allé chez Crashmidnick, aussi communément appelé Crashou, pour faire des tests avec sa machine et son système.


    Premier test avec mon HD sur sa machine : Aucun souci sous OS4, l'USB fonctionne parfaitement, ce qui valide mon système (l'inverse aurait été étrange puisque mon système est "de base"). Par contre, sous MorphOS, pas d'USB... Etrange !

    Différents tests matériels sur ma machine : Installation de la carte PCI USB 2.0 de Crash dans ma machine et ce, sur les différents ports PCI du Pegasos 2, rien, pas d'USB sous OS4...
    Test de la barrette mémoire de Crash, idem... 
    Test d'une nouvelle alim', idem...
    Au final, j'arrive à convaincre Crashou de sortir tant bien que mal son HD de sa machine pour l'installer sur la mienne et là... idem... toujours pas d'USB.

    On en convient donc qu'il y a un souci soit hardware sur la CM, soit de firmware. En effet, bien qu'ayant une carte mère 2B5 (dernier modèle) avec un firmware datant d'avrl 2005, je n'ai pas de reconnaissance de mon clavier USB  dans le firmware... (clavier qui me semble était pourtant bien reconnu sur mon ancien Pegasos 2, ni de celui de Crash pourtant bien reconnu sur sa machine avec son firmware daté d'août 2004).


    Finalement : Après avoir flashé mon Pegasos 2 avec un firmware plus récent (demande faite auprès de bPlan), j'ai eu la bonne surprise de voir mon clavier et ma souris USB (branchés sur les deux ports externes de la carte mère) s'allumer tous les deux ! Et mon clavier USB est reconnu sous le firmware et me permet de taper mes commandes et les choix de mon boot-menu, youhou !

    J'ai évidemment booté ensuite sous MorphOS, qui fonctionne toujours bien, et enfin sous OS4. J'ai d'abord eu la joie de voir ma souris USB s'allumer à l'image de boot d'OS4 ! Yeah ! Mais le boot s'arrêtait à cette splash screen... En fait, le nouveau firmware ne semble pas reconnatre la commande qui me permet de spécifier la partition de boot d'OS4. De ce fait, OS4 essayait de démarrer sur la partition qui avait la plus haute priorité, à savoir ma partition MorphOS ^^ En modifiant mes paramètres de priorité, rulez !

    Problème résolu ! J'ai donc un Pegasos 2 G4 100% fonctionnel, que ce soit sous MorphOS ou AmigaOS4.1FE.


    Je suppose donc, que contrairement à MorphOS, AmigaOS4.1 ne sait pas "initialiser" l'USB à son démarrage et laisse donc l'OF s'en charger, ce qui explique pourquoi, avec mon vieux firmware, je n'avais pas d'USB !


    Mille remerciements à Crashmidnick qui m'a bien dépanné et merci à bPlan de continuer à assurer le SAV pour cette bonne vieille machine qu'est le Pegasos 2.

    --
    /me est content, il a retrouvé internet (plus de réseau à la maison depuis 1 semaine) et un Pegasos 2 100% fonctionnel !


    Pegasos 2, Radeon 9000 64 Mo, 1 Go de mémoire, AmigaOS4.1 FE + MorphOS 3.9 en multiboot !
    Message édité par : BatteMan / 06-08-2016 14:09

      Afficher le profil de BatteManProfil  Ouvrir le site web de BatteManwww  Imprimer ce commentaireImprimer
    Aller à la page : [ 1 | 2 ]
    Sauter à :


    Tous les Logos et Marques sont déposés, les commentaires sont sous la responsabilité de ceux qui les ont publiés. AmigaOS 4.x est (c) Hyperion Entertainment

    Conception graphique du thème : PowerMetal, codage : Alexandre Balaban
    Certaines images sont © Martin \"Mason\" Mertz

    Temps : 1656971369.3482 seconde(s)