Bienvenue sur Le site des utilisateurs francophones actuels et futurs d'AmigaOS 4.x
Recherche
13 visiteur(s) et 0 membre(s) en ligne.
 
 
    Annonces Google

    Petites Annonces

il y a 1 annonces
    Liens

Toutes les informations sur :
  • Amiga OS 4:
    AmigaOS.net
  • Logiciels pour OS4 :
    OS4depot
  • Matériel Amiga :
    ACube Systems
  • Magazine papier :
    AmigaPower
  • Magazine en ligne :
    Obligement
  •     Activité du Site

    Pages vues depuis 25/07/2007 : 105 724
    • Nb. de Membres : 172
    • Nb. d'Articles : 1 049
    • Nb. de Forums : 17
    • Nb. de Sujets : 17
    • Nb. de Critiques : 19

    Top 10  Statistiques

      
    Modéré par : K-L Creols Elwood 
    Index du Forum > > Création-Développement > > smTube : lecture directe YouTube Qt
    45 pages [ 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 ]
    AuteursmTube : lecture directe YouTube Qt
    zzd10h
    3722       

    zzd10h
      Posté : 16-09-2013 23:02

    Merci pour ton test,
    mais quand tu lances le streaming qui plante, tu n'as pas une console qui reste ouverte pendant 10 secondes et qui te dit que les versions MPlayer qui marchent sont
    MUIMplayer
    RA-Mplayer 4.2.4 ?

    La 4.2.3 ne permet pas de faire du streaming, pas de ma faute

    Pour le bouton droit, oui des fois ça fait un double-clic,certainement une sensibilité Qt.

    Pourrais-tu retester avec MUI-Mplayer (et en modifiant au besoin le chemin de MPlayer dans le REXX Data/PlayVideo.rexx) ?

    Ou peut-être que tu as la 1ère version sans le message indiquant les versions de mplayer supportées ?


    Merci

    Je crois que je ne vais pas le mettre sur OS4Depot celui-là, je vais avoir trop de questions, trop de "c'est de la ... ce truc, il marche pas !" malgrè le readme et le message dans la console
    Je vais le garder pour mon gamin et moi

    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE
    Message édité par : zzd10h / 16-09-2013 23:15
    Message édité par : zzd10h / 23-09-2013 00:07

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    Lio
    925      

    Lio
      Posté : 16-09-2013 23:26

    bon là ca marche en streaming mais je crois que mon appdir:mplayer confond ra-mplayer et mui-mplayer donc suivant lequel a été lancé en dernier, il prend le mauvais !

    le pb semble être que les 2 mplayers s'appelent mplayer

    et oui j ai bien cette fenêtre mais elle ne reste pas suffisamment de temps ouverte ni assez haute pour lire les infos importantes !

    tu fais comme tu veux mais je pense qu il y a avantage à distribuer cette version

    A1G4/Radeon9000PRO/1024Mo depuis 2003

      Afficher le profil de LioProfil  Imprimer ce commentaireImprimer
    zzd10h
    3722       

    zzd10h
      Posté : 16-09-2013 23:36

    Yes, enfin un essai concluant

    Pour l'appdir, c'est pour ça que je mettais
    "en modifiant au besoin le chemin de MPlayer dans le REXX Data/PlayVideo.rexx"

    C'est dans ce rexx, que tu peux mettre les options, l'emplacement de mplayer et le temps d'attente de la fenêtre de debug (normalement 10 secondes, à moins que je l'ai laissé à 3 secondes...)

    Donc, à moins de lire la doc (ok, il n'y en a pas pour l'instant), de modifier à la main le rexx selon la version de mplayer utilisée... Pas trés user-friendly tout ça et j'ai la flemme de faire un programme de config...

    Artblink, tu es dans le coin, pour toi c'est mieux avec la dernière version ?

    En tout cas, merci Lio pour ton acharnement à tester

    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    Lio
    925      

    Lio
      Posté : 16-09-2013 23:43

    en fait le playvideo.rexx n est pas très clair, en tout cas pour moi, et même s il est en français !
    le plus simple c est de mettre en majuscule et en commentaire ce qu il y a à changer (le chemin et les options videos) et juste au dessus (ou en dessous mais c est moins logique) de la ligne à modifier.

    c est presque ça mais faudrait le rendre un poil plus lisible !

    sinon dans les options du programme, il n y a que mplayer mais pas par ex mui-mplayer voire dvplayer
    c est "hard codé" ?

    A1G4/Radeon9000PRO/1024Mo depuis 2003

      Afficher le profil de LioProfil  Imprimer ce commentaireImprimer
    zzd10h
    3722       

    zzd10h
      Posté : 16-09-2013 23:53


    Oui, il n'y a que mplayer, j'avais mis dvplayer au début et je passais mplayer ou dvplayer au rexx mais vu que dvplayer ne lit aucun des formats de youtube je n'ai laissé que mplayer.
    Et comme tu l'as remarqué, MUIMplayer ou RAMplayer ont le même nom d'exécutables.
    Donc, oui, j'ai hardcodé MPlayer.

    Pour le rexx, oui, je vais mettre les options à modifier en majuscules, je les ai simplement regroupé pour l'instant.

    C'est à ça que ça sert de demander des tests, des yeux neufs, merci

    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    sinisrus
    2861       

    sinisrus
      Posté : 17-09-2013 13:41

    Marche tres bien ici juste dommage qu'il ne soit pas plus simple d'activé les option de mplayer
    au moin avec des tooltype dans l'icon plutôt que d'aller chercher un fichier de config

    c'est supporté les tooltype avec Qt?

    --
    Coin coin... amitheme.amiga-ng.org
    Sam460 1,15Ghz - OS4.1FE - Radeon4650 1Go - 2Go de ram

      Afficher le profil de sinisrusProfil  Ouvrir le site web de sinisruswww  Imprimer ce commentaireImprimer
    zzd10h
    3722       

    zzd10h
      Posté : 17-09-2013 13:52

    Merci pour le test (avec MUIMplayer et "-vo cgx_wpa - ache 8192" , je présume)

    Pour les tooltypes
    Si c'est supporté en C++, cela devrait marcher... mais... j'ai la flemme.

    Soit la personne intéréssée va mettre juste 3 secondes à modifier ses options, une fois pour toute.

    Soit moi, je vais mettre des heures pour trouver comment implémenter le truc en C++ (je n'ai jamais ouvert de librairies système en C++, je sais juste le faire en C) !

    A choisir, je préfère passer du temps sur mes programmes à moi



    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    xray
    580      

    xray
      Posté : 17-09-2013 14:36

    LO

    heu je prends en route...mais je constate que je n'ai pas le choix des lecteurs dans les prefs. T'as pas un fichier "playvideo.rexx" déjà configurer pour tester ou comment le configurer ja' pô trouvé?

      Afficher le profil de xrayProfil  Ouvrir le site web de xraywww  Imprimer ce commentaireImprimer
    zzd10h
    3722       

    zzd10h
      Posté : 17-09-2013 15:07

    Salut XRay,

    Oui, en effet comme expliqué plus haut
    "Oui, il n'y a que mplayer, j'avais mis dvplayer au début et je passais mplayer ou dvplayer au rexx mais vu que dvplayer ne lit aucun des formats de youtube je n'ai laissé que mplayer.
    Et comme tu l'as remarqué, MUIMplayer ou RA-Mplayer ont le même nom d'exécutables.
    Donc, oui, j'ai hardcodé MPlayer. "


    Pour le REXX (dans Data/PlayVideo.rexx), cela dépend de ta config, avec ou sans Overlay.

    Attention, par simplicité, MPlayer doit être MUIMplayer (à moins que tu n'ais la version SDL-SVN-r32561-snapshot-4.2.4)

    si SAM460 ou X1000 :

    OPTION = "-vo cgx_wpa -cache 8192"
    MPLAYER = "APPDIR:MPlayer"
    ou
    MPLAYER = "Work:MUIMplayer/Altivec/MPlayer"


    Si AmigaOne, Peg2 ou SAM440
    OPTION = ""
    MPLAYER = "APPDIR:MPlayer"
    ou
    MPLAYER = "Work:MUIMplayer/Altivec/MPlayer"


    ou sinon, j'ai celui-là que je viens de mettre dans l'archive

    http://zzd10h.amiga-ng.org/Qt/PlayVideo.zip

    Toute la config est dans ce bloc

    /* UPDATE THESE PARAMETERS IF NEEDED */

    /* TAKE CARE TO SPECIFY THE PATH OF MUI-MPlayer OR SDL MPlayer SVN-r32561 TO ALLOW STREAMING IN OPTION MPLAYER = "" */
    /* Others players or, even, other versions of MPlayer are NOT supported */


    MPLAYER_OPTIONS = ""
    DEBUG = ON
    WAIT = ON
    SECONDS = 10
    MPLAYER = "APPDIR:MPlayer"


    /* END OF UPDATABLES PARAMETERS */

    /* examples */
    /*MPLAYER = "WORK:MPlayer/Altivec/mplayer-4.2.4" */
    /*MPLAYER = "APPDIR:mplayer-4.2.4" */
    /*MPLAYER = "APPDIR:mplayer_MUI_443"*/
    /*MPLAYER_OPTIONS = "-vo cgx_wpa -cache 8192"*/ /* for MUI-Mplayer without overlay */



    http://apps.amistore.net/zTools
    X1000 - 1,8ghz - 4go RAM - Radeon R7-250X - AOS4.1.6/FE
    Message édité par : zzd10h / 17-09-2013 21:08

      Afficher le profil de zzd10hProfil  Ouvrir le site web de zzd10hwww  Imprimer ce commentaireImprimer
    Creols
    2542       

    Creols
      Posté : 17-09-2013 17:22

    Arrivée (sans encombre) à st Flour, notre étape du jour, je ne pourrai tester ton nouveau bébé qu'à notre retour le mardi de la semaine prochaine

    Continue de peaufiner ce programme pour m'éviter les affres des testeurs


    -- Sam 460 + X1000

      Afficher le profil de CreolsProfil  Imprimer ce commentaireImprimer
    Aller à la page : [ 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 ]
    Sauter à :


    Tous les Logos et Marques sont déposés, les commentaires sont sous la responsabilité de ceux qui les ont publiés. AmigaOS 4.x est (c) Hyperion Entertainment

    Conception graphique du thème : PowerMetal, codage : Alexandre Balaban
    Certaines images sont © Martin \"Mason\" Mertz

    Temps : 1488284214.0553 seconde(s)